Reply to topic  [ 2 posts ] 
Problem with uploading Lisa M 
Author Message

Joined: Fri Aug 31, 2012 8:57 am
Posts: 1
Post Problem with uploading Lisa M
Hi guys!

I have really strange problem with uploading Lisa M 2.0. Compilation goes without any problems through, however the upload over an USB begins with “Programming memory at 0x08002000” but stucks and never ends.

What could be a problem here?


Fri Aug 31, 2012 9:01 am
Profile
Site Admin
User avatar

Joined: Tue Jun 21, 2011 7:09 pm
Posts: 69
Post Re: Problem with uploading Lisa M
Hi,

When is the upload getting stuck? If it is at 0x8020000 then you may have an older version of the bootloader that only supported up to 128kb of flash. The current version on github (https://github.com/paparazzi/luftboot) will allow you to flash all 256kb of the available flash.

If that is the case you can follow the instructions in the wiki (http://paparazzi.enac.fr/wiki/Lisa/M_v2 ... Bootloader) and update the bootloader.

It would be much nicer to actually create a payload (application) for luftboot that upgrades the bootloader. Then it is not necessary to use the serial interface if one does not have a JTAG adapter making everything much easier. Maybe someone is feeling up to the challenge and make that happen? Just send a pull request to luftboot repository on github. :)

Cheers Piotr

(edit) this is an updated copy of my email to the paparazzi mailing list http://lists.nongnu.org/archive/html/pa ... 00234.html


Fri Aug 31, 2012 6:51 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.