forum.thequadshot.com
http://thequadshot.com/forum/

compilation error
http://thequadshot.com/forum/viewtopic.php?f=6&t=819
Page 1 of 1

Author:  david.erzen [ Mon Aug 27, 2012 7:25 pm ]
Post subject:  compilation error

Hello

i have tried to compile the firmware because I have different radio.
i get following error:

Code:
firmwares/rotorcraft/main.c:192: error: 'RADIO_EXPO' undeclared (first use in this function)
firmwares/rotorcraft/main.c:192: error: (Each undeclared identifier is reported only once
firmwares/rotorcraft/main.c:192: error: for each function it appears in.)
make[1]: *** [/home/david/paparazzi/var/QS4_M2A2/ap/firmwares/rotorcraft/main.o] Error 1
make: *** [ap.compile] Error 2


Any idea? :)

Cheers,
David

Author:  esden [ Mon Aug 27, 2012 8:22 pm ]
Post subject:  Re: compilation error

Hi,

I assume you are using a PPM receiver. You need to define a channel called EXPO (setting the fly by wire command expo setting) in your radio file. Look in conf/radios/QS1RX6.xml for an example.

Cheers Esden

Author:  david.erzen [ Mon Aug 27, 2012 8:48 pm ]
Post subject:  Re: compilation error

Hey Esden,

thanks for helping me.
I managed to to compile (with the EXPO correction) and upload (using sudo, otherwise I didn't get the permission).
So, I switched everything on and lots of lights appeared :).
Is there any light that says:"Ok, I see Rx and I understand it."?
I haven't got time to browse through Mocha user manual if there is any info about that.
Cheers,

David

p.s. Great job on quadshot. It got me just two afternoons to assemble it.

Author:  psinha [ Mon Nov 17, 2014 7:22 pm ]
Post subject:  Re: compilation error

Yes

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/