Reply to topic  [ 2 posts ] 
Easter egg - stabilized tilt camera mount 
Author Message

Joined: Tue Jun 21, 2011 7:33 pm
Posts: 37
Location: Santa Cruz, CA
Post Easter egg - stabilized tilt camera mount
Hey all, since more of you are sharing videos I thought I'd reveal a small Easter egg in the Quadshot software - it can stabilize a tilt mount!

Attach a small tilt mount (we use this:http://www.hobbyking.com/hobbyking/store/__12875__FPV_Fiberglass_Pan_Tilt_Camera_Mount_L_Size_.html and put the QS camera screw through the hole meant for the pan servo) and plug the tilt servo into channel 7. Set up the mount and servo so that when the QS is sitting on its tail (Mode 1), the camera is pointed horizontal (or slightly below horizontal) at one end of its range of motion, and can tilt the camera up until it is looking vertically. The QS software will then keep the mount at a constant angle relative to the ground regardless of the vehicle pitch or flight mode.

If you have an Espresso or have looked around in conf/airframes/esden, you have probably noticed the extra servo and axis in your airframe file already 8-) You can assign your TX channel 7 to a knob or lever to adjust the camera pitch as well.

I'll try and post some pics/video soon.

Happy holidays!
//Jeff

_________________
Mechanical Engineer @ Transition Robotics, Inc.
PM or email me at [jkg atsign transition hyphen robotics dot com] if you'd like to help edit the Quadshot wiki!


Wed Dec 26, 2012 10:01 pm
Profile WWW
User avatar

Joined: Wed Aug 10, 2011 3:22 am
Posts: 31
Location: New Market, VA
Post Re: Easter egg - stabilized tilt camera mount
Thanks for posting Jeff!

I had some questions on the programming/configuration of this feature.

What is the range of values for the servo commanded value?
What is the range of the hover_pitch variable?

I am trying to alter the config for my tilt mount and have had some success but not full understanding.

The default values for the range of motion are:
(In hover mode)
COMMAND_VALUE = 3740+(1.85*hover_pitch)

(In forward mode)
COMMAND_VALUE = -6700

The servo range has a MIN of 1700, and a MAX of 1000.

I know I could probably figure all of this out if I had a debugger - any suggestions?


Wed Dec 26, 2012 11:37 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.