Reply to topic  [ 8 posts ] 
Elevon Flapping 
Author Message
User avatar

Joined: Wed Aug 10, 2011 3:22 am
Posts: 31
Location: New Market, VA
Post Elevon Flapping
Hi Quadshooters!

It seems my Quadshot has developed a little problem, the left elevon servo has started flapping/twitching.
It only slightly affects flight in mode 1 but I am afraid it will cause major issues in mode2/3.
This is NOT being caused by the Lia as I connected the servo up to a standalone RX and it does the same thing.

Take a look at the video and let me know what you think:

http://youtu.be/Zoed92VYLmo

Do you think this demands a new servo?
http://transition-robotics.com/collections/quadshot-parts/products/quadshot-servo-set

Any suggestions on how I would replace the servo (aside from the obvious)?
Should I cut the spar cover off to get at the wire or should I do something else?

Thanks a bunch!
Keep those Quadshots flying!
-Bob


Thu Dec 13, 2012 11:01 pm
Profile
User avatar

Joined: Wed Aug 10, 2011 3:22 am
Posts: 31
Location: New Market, VA
Post Re: Elevon Flapping
I went ahead and replaced it with another servo.
To simplify replacement I simply cut the wire right at the old servo and soldered in the new one (hextronik 9g HXT900) I had lying around.

This servo has the same direction as the old one and seems to be the same speed and throw.
Only time (and test flight) will tell if this is a good match with the other one.

On a related note, I opened up the old servo and found one of the small gears had teeth missing:
Image


Fri Dec 14, 2012 5:20 am
Profile

Joined: Wed Jun 22, 2011 5:24 pm
Posts: 148
Post Re: Elevon Flapping
We also cut the wire and solder in a new servo right at the mounting location. Nylon gears may be broken by simply turning the servo with an external force while it is off or on. I have had a plane not pull up from a dive, opened the elevator servo, and found that one of the internal wires had broken.


Mon Dec 17, 2012 7:50 pm
Profile
User avatar

Joined: Wed Aug 10, 2011 3:22 am
Posts: 31
Location: New Market, VA
Post Re: Elevon Flapping
It flies better than ever!
I may have been having problems with that servo since the beginning.


Mon Dec 17, 2012 11:16 pm
Profile

Joined: Tue Jun 21, 2011 7:33 pm
Posts: 37
Location: Santa Cruz, CA
Post Re: Elevon Flapping
Sweet videos! Where are you located? Your field puts our little one in the woods to shame :-) We're gonna have to get a Hero3 for the holidays, the 4K/15 looks pretty nice, but for flying I prefer 1080p/60 :D

//Jeff

_________________
Mechanical Engineer @ Transition Robotics, Inc.
PM or email me at [jkg atsign transition hyphen robotics dot com] if you'd like to help edit the Quadshot wiki!


Fri Dec 21, 2012 6:53 pm
Profile WWW
User avatar

Joined: Wed Aug 10, 2011 3:22 am
Posts: 31
Location: New Market, VA
Post Re: Elevon Flapping
Thanks! I am in New Market, VA.
http://goo.gl/maps/JtjY3

Tons of agricultural places to fly - I just ask the farmer (who usually laughs at me and says "Don't hit a cow!" or some such reply).

I prefer the 1080p60 settings myself.
Once I get a little better at video editing (and a faster PC to edit on!) I might switch to a higher resolution at 30fps to do image stabilization at 1080p.

I think the 4k video got mutilated by YouTube... I will have to make another and maybe try Vimeo.

I am working on a tilt gimbal for the camera.
If it works out I can wright up a Wiki article.
Does the firmware version that shipped with the Lia have the built-in tilt output on the spare servo pin(s)?

-bob


Fri Dec 21, 2012 8:45 pm
Profile

Joined: Tue Jun 21, 2011 7:33 pm
Posts: 37
Location: Santa Cruz, CA
Post Re: Elevon Flapping
Yes the stock firmware has the tilt code enabled (use servo output 7). I also posted about it separately in this forum.
I'll try and put up some pics/video soon.
//Jeff

_________________
Mechanical Engineer @ Transition Robotics, Inc.
PM or email me at [jkg atsign transition hyphen robotics dot com] if you'd like to help edit the Quadshot wiki!


Wed Dec 26, 2012 10:03 pm
Profile WWW
User avatar

Joined: Wed Aug 10, 2011 3:22 am
Posts: 31
Location: New Market, VA
Post Re: Elevon Flapping
I should have posted an update - I got it working.

I will work on documenting and videoing my setup if anyone wants to see how I did it (I had to tweak the camera control XML and servo values).
It's still not perfect - perhaps I will have some time to work on it later...


Wed Dec 26, 2012 11:22 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.